Back to overview
Maintenance

Scheduled performance upgrades

Mar 14, 2026 at 03:00am UTC  –  Mar 14, 2026 at 05:00am UTC
Affected services
Cerebrum vID API
Cerebrum.com
Cerebrum vID Web
Document Verification API
Authentication API

Resolved
Mar 14, 2026 at 04:56am UTC

Maintenance complete.
Thank you for your understanding.

Created
Mar 14, 2026 at 03:00am UTC

We are performing server updates to our core APIs and infrastructure. Our applications may be intermittently unavailable for this period.