Back to overview
Degraded

Partial email delivery disruption (resolved)

May 1, 2026 at 9:45pm UTC
Affected services
Cerebrum vID API

Resolved
May 1, 2026 at 10:45pm UTC

The incident has been resolved.

Created
May 1, 2026 at 9:45pm UTC

We experienced a transient issue affecting email delivery for a subset of customers.
The incident started at approximately 4:45 PM CDT and lasted about an hour.
Email delivery has been fully restored, and services are operating normally.