Back to overview
Degraded

Degraded Performance on Transactional Emails and vID Invites

Jun 4, 2026 at 10:59pm UTC
Affected services
Cerebrum vID API

Resolved
Jun 5, 2026 at 12:43am UTC

The incident has been resolved.

Updated
Jun 4, 2026 at 11:56pm UTC

The underlying issue with our third-party email provider has been resolved. We are currently monitoring our delivery queues as the backlog of delayed emails clears out.

You should see pending emails arriving shortly. We will provide a final update once delivery times return to baseline.

Created
Jun 4, 2026 at 10:59pm UTC

We have identified an issue with a third-party vendor responsible for our email delivery services, which is causing a backlog and subsequent delays in sending transactional messages.

The provider is currently implementing a fix. All outgoing emails are safely queued and will be processed chronologically as performance recovers. No action is required on your part.