Back to overview
Resolved
API instability
Jul 2, 2026 at 4:49pm UTC
Affected services
Cerebrum vID API
Cerebrum vID Web
Document Verification API
Authentication API
Criminal Search API
Resolved
Jul 2, 2026 at 4:59pm UTC
We have deployed a fix to our production systems resolving the cause of the issue.
Affected services
Created
Jul 2, 2026 at 4:49pm UTC
Our API services are currently under heavy load and failing to respond to requests. The engineering team is investigating.
Affected services